Уязвимости и их устранение. Защита от разных способов взлома.

We have detected that your server is using PHP 5.5.x which is obsolete

Alexey Samsonov » 16 фев 2018, 01:04

Доброго времени суток, форумчане!
Кратко опишу ситуацию.
Обновил сайт на Joomla! 3.6.5 до 3.8.4.
У меня высветилась в админке вот такая ошибка:
We have detected that your server is using PHP 5.5.38 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 5.6 or later which will receive security updates at least until 31.12.18. Please ask your host to make PHP 5.6 or a later version the default version for your site. If your host is already PHP 5.6 ready please enable PHP 5.6 on your site's root and 'administrator' directories – typically you can do this yourself through a tool in your hosting control panel, but it's best to ask your host if you are unsure.
Насколько я понимаю, это как-то связано с версисей PHP. Нормально ли вообще это? У меня хостинг nic.ru, может кто сталкивался с такой же проблемой?
Alexey Samsonov
 
Сообщения: 10
Зарегистрирован: 22 фев 2015, 19:43

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Pasha programmist » 16 фев 2018, 11:25

Ну подключите на хостинге модуль PHP поновее, на nic.ru в панели управления там насколько помню всё это есть . Вроде в ошибке про это пишут, мол, достаточно новую версию PHP использовать так как старая небезопасна.
Единственно, только нужно следить, все ли сторонние расширения Joomla (если таковые есть) на сайте, корректно работают с выбранной версией PHP.
Можете дать адрес сайта, а то так не видя, тоже не совсем правильно гадать обо всём.
Pasha programmist
 
Сообщения: 9
Зарегистрирован: 30 апр 2015, 22:52

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Alexey Samsonov » 16 фев 2018, 11:51

Спасибо! Адрес что-то выкладывать не хочу.. лучше отправлю Вам в личное сообщение.
Alexey Samsonov
 
Сообщения: 10
Зарегистрирован: 22 фев 2015, 19:43

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Александр » 16 фев 2018, 13:14

Можете мне тоже в личку отправить, гляну.
Александр
 
Сообщения: 252
Зарегистрирован: 20 мар 2014, 17:05

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Alexey Samsonov » 16 фев 2018, 13:31

Обоим отправил. Заранее спасибо! Жду комментариев от вас, пока ничего на хостинге делать не буду.
Alexey Samsonov
 
Сообщения: 10
Зарегистрирован: 22 фев 2015, 19:43

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Pasha programmist » 16 фев 2018, 23:08

На nic.ru вроде не сложно подключить другой модуль PHP https://www.nic.ru/help/php-nastrojka-m ... .html#p2.1

Попробуйте, если что отвалится, просто назад старый модуль подключите. Вы, кстати, смелый человек — сами обновили Joomla до 3.8.4.
Кстати, для создания галерей у Вас установлен плагин https://extensions.joomla.org/extension/sigplus/ что ты вы его не используете?
Еще, у вас вижу используется компонент гостевой книги https://extensions.joomla.org/extension ... -reloaded/

Короче за всем этим нужно следить, желательно и версии этих расширений не допускать совсем чтобы устаревали т. е. у них своё обновление. При обновлении Joomla нужно тестировать работоспособность всех расширений. Лучше заранее в интернете читать о возможных проблемах из-за несовместимости версий.

Кстати, именно поэтому я редко берусь за разовые работы, что-то там кому-то обновить, например. Всё это не охота объяснять, как какая-то мелочь может оказать не практике большой проблемой. Одно то, что по-хорошему перед любым обновлением нужно делать резервную копию сайта – чего стоит. А ведь по-хорошему, копия всегда должна быть не одна.. Всё это кому объяснять..
Ладно, это я так разболтался что-то ;)
Pasha programmist
 
Сообщения: 9
Зарегистрирован: 30 апр 2015, 22:52

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Alexey Samsonov » 17 фев 2018, 01:51

Включил PHP 5.6, 7 пока не стал. Кстати, 6 версии я так понял не существует? Вроде все работает.
А насчет галереи, что-то я и забыл, что она у меня есть. как пользоваться не знаю..
Alexey Samsonov
 
Сообщения: 10
Зарегистрирован: 22 фев 2015, 19:43

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Александр » 17 фев 2018, 18:49

А Sigplus смотрю, достаточно крутая штука. То что интерфейс управления аскетичный — даже хорошо, меньше шансов, что админка глючить будет. А так смотрю, никакого MooTools не требует, своя JavaScript-библиотека. Даже EXIF, IPTC данные может брать из изображений, такое вообще не у всех бывает.
Вот на русском инструкция https://joomlaforum.ru/index.php/topic,177189.0.html
Не знаю, насколько она адекватна, я по-английски всегда всю инфу на сайтах разработчиков читаю, вот родная инструкция к этой галерее: https://hunyadi.info.hu/sigplus/sigplus-basic-usage.
Александр
 
Сообщения: 252
Зарегистрирован: 20 мар 2014, 17:05

Галерея изображений Sigplus

Alexey Samsonov » 20 фев 2018, 20:44

С галереей в основном разобрался. Нормальное управление у неё, мне, например всё вроде понятно. В папку положил, код в тексте прописал типа
{gallery layout=flow}myfolder{/gallery}
и вуаля..
Вы, наверное, на Юкозе (Ucoz) никогда не работали.. — вот там действительно интерфейс е..ый ) А с Joomla я себя белым человеком чувствую!!!

UPD.
Даже скриншоты сделал, сюда выложу.
Галерея изображений Sigplus, скриншот административной панели Joomla! 3

Галерея изображений Sigplus — скриншот административной панели Joomla! 3
Alexey Samsonov
 
Сообщения: 10
Зарегистрирован: 22 фев 2015, 19:43

Re: We have detected that your server is using PHP 5.5.x which is obsolete

Александр » 20 фев 2018, 22:02

Юкозе (Ucoz)
— вы зачем здесь такие кошмарные слова пишите!!! :shock:
Было, кстати несколько раз работал с ними. Да о чем тут говорить, это же как и любой конструктор создавалось для клинически наивных))
Александр
 
Сообщения: 252
Зарегистрирован: 20 мар 2014, 17:05

След.

Вернуться в Безопасность